Apps go blank after AppGiniHelper update

This sub-forum is for discussing all topics related to AppGini Helper JavaScript Library, provided by bizzworxx as a third-party AppGini plugin.
Post Reply
kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-23 13:13

Hi Guys,
Today I had the strangest problem. I've installed the new version of AppGiniHelper on 4 of my apps on the same server.
All apps got blank when accessing from outside, but are accessible from localhost. If I remove AppGiniHelper lib it all works fine.
I've tried to install the older version but all apps remain inaccessible from outside.
I' using WAMP v.4.6. with PHP 7.1.33 and Appache 2.4.23. I really don't know what happened. I've removed all custom js to avoid any bad scripting but even a completely new app just go blank when I enable AppGiniHelper in header-extras.php. I've tried to restart all services and restart the whole machine but nothing changes. I've re-generated again all apps with Appgini v22.14 revision 1293 but nothing changed. I think something happened with the webserver but cant figure it out. There is nothing in the logs - php, apache, mysql.

User avatar
jsetzer
AppGini Super Hero
AppGini Super Hero
Posts: 1435
Joined: 2018-07-06 06:03
Location: Kiel, Germany
Contact:

Re: Apps go blank after AppGiniHelper update

Post by jsetzer » 2022-06-23 14:29

Just to be sure: there are different AppGini Helper libraries for both, client side and server side. Are you talking about AppGini Helper Javascript Library? Then just remove the <script> include in header-extras.php and check if your site works fine again.

From my experience if the page is blank usually there is a php error. Check the serverside php version. Many providers still offer and configure php 5.x by default, which is less secure and less performant and deprecated. New php classes or functions may not work with old php 5 installations. I strongly recommend migrating to php 8.x..
Kind regards,
<js />

My AppGini Blog:
https://appgini.bizzworxx.de/blog

User avatar
jsetzer
AppGini Super Hero
AppGini Super Hero
Posts: 1435
Joined: 2018-07-06 06:03
Location: Kiel, Germany
Contact:

Re: Apps go blank after AppGiniHelper update

Post by jsetzer » 2022-06-23 14:50

Sorry, I did not see you have already written you are using php 7.4.

Just in case Appgini helper javascript library causes the blank screen, remove it or check for errors in console.
Kind regards,
<js />

My AppGini Blog:
https://appgini.bizzworxx.de/blog

kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Re: Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-23 17:59

Thanks for your suggestion jsetzer but I'm positive already that the newest version of Appgini Helper Javascript library is in conflict with something in my system. I've succeeded to downgrade to previous version and now all works fine. When I update to the newest version the app immediately goes blank, no PHP error, no console errors, just nothing. After I downgrade CRTL+F5 does not load the downgraded library and the app is still blank. I need to clear the entire browsing data for the app to return to normal. There is definitely a conflict somewhere but I don't know where and how to look for it. The interesting part is that when I update to the newest version and test on localhost it works fine. From outside is blank. With the downgraded version is fine both from outside and on localhost. I'm just stunned of this issue.

User avatar
jsetzer
AppGini Super Hero
AppGini Super Hero
Posts: 1435
Joined: 2018-07-06 06:03
Location: Kiel, Germany
Contact:

Re: Apps go blank after AppGiniHelper update

Post by jsetzer » 2022-06-23 18:24

I can send latest development version (alpha) to you for testing. If you are interested, please send your ordernumber by email to [email protected]. I'm successfully using it with AG 22.14.
Kind regards,
<js />

My AppGini Blog:
https://appgini.bizzworxx.de/blog

kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Re: Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-23 19:46

Thanks Jan,
I've sent to your email my order number. Meanwhile I've updated Wampserver to latest version and installed latest Apache. I cant put the new apache to work and now I'm staring to think that it could be some redirection function problem because of bad apache configuration on my system. Because at first the app starts to load I can clearly see the header and then exactly after the Appgini Helper Library is loaded the app goes blank. I looks to me like some bad redirection.

kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Re: Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-24 06:33

So I have tested on a new server. Still the same problem.
I've tested how the files are loaded in chrome dev tools and there is clear stalling when Appgini Helper Library (version 2022.02.08.1) loads compared to the older version (2021.07.29.1) - see attached screenshots.
Attachments
helper_problem2.png
helper_problem2.png (177.81 KiB) Viewed 257 times
helper_problem1.png
helper_problem1.png (155.23 KiB) Viewed 257 times
helper_ok.png
helper_ok.png (161.92 KiB) Viewed 257 times

User avatar
jsetzer
AppGini Super Hero
AppGini Super Hero
Posts: 1435
Joined: 2018-07-06 06:03
Location: Kiel, Germany
Contact:

Re: Apps go blank after AppGiniHelper update

Post by jsetzer » 2022-06-24 06:39

Can you please check that error caused by bg.js. I don't know that script file. Maybe it throws an exception which stops follow up script calls from being executed.

Are there more (red) errors in console which we cannot see on your screenshots?
Kind regards,
<js />

My AppGini Blog:
https://appgini.bizzworxx.de/blog

kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Re: Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-24 07:13

/resources/datepicker/js/lang/bg.js net::ERR_ABORTED 404 (Not Found).
So because I have Bulgarian translation the datepicker is looking for bg.js which is not there. I don't think this is the problem.

kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Re: Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-24 07:21

I've put the bg.js and now the error is gone. But this file is loaded after the Appgini Helper Library and the last screenshot is actually with the older version. With the new version the loading does not reach to this file at all. App is still stalling with the new library. I can't understand why it is working fine on localhost.

kerelov
Veteran Member
Posts: 38
Joined: 2020-04-17 21:20
Location: Bulgaria

Re: Apps go blank after AppGiniHelper update

Post by kerelov » 2022-06-24 07:27

Here is a screenshot of the same app accessed on localhost. Everything works fine with the new library. If I access it from outside it stalls.
Attachments
helper_localhost.png
helper_localhost.png (136.12 KiB) Viewed 252 times

User avatar
zibrahim
Veteran Member
Posts: 106
Joined: 2020-01-28 18:30
Location: Malaysia

Re: Apps go blank after AppGiniHelper update

Post by zibrahim » 2022-06-26 04:38

Hi Jan,
I am having exactly the same issue mentioned above using the version 2022.02.08.1.
Replacing the file with version 2021.07.29.1 will only work after you have clear the browser cache.

Thanks.
Zala.
Appgini 22.13, MacOS 12.3.1 Windows 10 on Parallels.

User avatar
jsetzer
AppGini Super Hero
AppGini Super Hero
Posts: 1435
Joined: 2018-07-06 06:03
Location: Kiel, Germany
Contact:

Re: Apps go blank after AppGiniHelper update

Post by jsetzer » 2022-06-27 05:04

zibrahim wrote:
2022-06-26 04:38
Hi Jan,
I am having exactly the same issue mentioned above using the version 2022.02.08.1.
Replacing the file with version 2021.07.29.1 will only work after you have clear the browser cache.

Thanks.
Please send your order number to [email protected].
Kind regards,
<js />

My AppGini Blog:
https://appgini.bizzworxx.de/blog

Post Reply