Lookup field not showing data.

If you're a new user of AppGini, feel free to ask general usage questions, or look for answers here.
Post Reply
User avatar
Jay Webb
Veteran Member
Posts: 55
Joined: 2017-08-26 15:27
Contact:

Lookup field not showing data.

Post by Jay Webb » 2019-07-22 16:14

I'm using AppGini 5.76 rv.1058

Lookup field SURNAME not showing data on CSV import.

First, all tables have field "ID".
I have a table called "MARRIAGES", with a lookup field called "SURNAME", that a looks to table "ADD_SURNAME", field "SURNAME_LIST".

There are 2,656 "MARRIAGE" records I'm trying to import by way of a CSV, but as field "SURNAME" is a "lookup field" and it automatically gets set to data type (integer) the text wont import and is not looking to "SURNAME_LIST to populate.

I did import the surnames into table "ADD_SURNAMES" field "SURNAME_LIST" successfully, as there were only 16 different spellings of the same surname for the 2,656 "MARRIAGE" records.

Question; how to get data imported for table "MARRIAGES" and look to values in "SURNAME_LIST" to populate table "MARRIAGES" field "SURNAME" and still have it as a lookup field, because new spelling of surname will be added over time, there is over 25 different ways to spell the same surname.

I hope this is possible and thank you for any assistance.
What we envision, we make happen.

pböttcher
AppGini Super Hero
AppGini Super Hero
Posts: 525
Joined: 2018-04-01 10:12

Re: Lookup field not showing data.

Post by pböttcher » 2019-07-22 16:31

Hi,
if I remember correctly, you need to use the integer value of the lookup for your import, not the final value.
Maybe you can try that.

User avatar
Jay Webb
Veteran Member
Posts: 55
Joined: 2017-08-26 15:27
Contact:

Re: Lookup field not showing data.

Post by Jay Webb » 2019-07-22 16:48

Thanks for replying,

Do you mean use the ID# for the surname spelling in SURNAME_LIST as the value in table MARRIAGES field SURNAME?
What we envision, we make happen.

User avatar
Jay Webb
Veteran Member
Posts: 55
Joined: 2017-08-26 15:27
Contact:

Re: Lookup field not showing data.

Post by Jay Webb » 2019-07-22 17:01

Hey pbottcher!

That did it, just need to change surnames to ID# and it worked.
What we envision, we make happen.

Post Reply