Page 1 of 1

Mass Update - Questions

Posted: 2019-07-30 14:34
by rprevost
Hello, thank you for this plugin. I ran into some issues that need to be addressed:
Mass Update is not working as expected. It is a simple update of a dropdown field with (Allow user to specify) and confirm first option.
The output seems ok:
Copying language-mass-update.js ... OK
Updating footer-extras.php to load nicEdit and language file Skipped
Table 'stage' has 1 commands
Generating /home/rejeanp/ OK
File stage-tv.js already exists, so we're updating it OK
Generating code in stage_batch_actions function OK

However, when trying to use it in the "Plus" menu after selecting a record, "nothing happens".
If the .axp file is changed and loaded in Mass Update, a new project is created and all previous created commands are lost. How to avoid recreating all previous commands if the .axp file has to be modified?
The console output is:

Code: Select all

stage_view.php:296 Uncaught ReferenceError: massUpdateCommand_94rwqn0r6eym0pec0i6x is not defined
    at HTMLAnchorElement.<anonymous> (stage_view.php:296)
    at HTMLAnchorElement.dispatch (jquery-1.12.4.min.js:3)
    at HTMLAnchorElement.r.handle (jquery-1.12.4.min.js:3)

Re: Mass Update - Questions

Posted: 2019-07-30 14:58
by rprevost

I also noticed that Mass Update Plugin modified one of some hook's file (stage.php) directly on the server side making it different from my original file located on my computer. It is like two distinct sources are writing the same file. I cannot imagine the mess that could result over time.

Maybe I am not using the correct procedure (modify file locally, update server file via FTP). With Mass Update modifying the file on the server, maybe I should first download the file from the server, modify it and then update the file on the server side via FTP.

Any suggestions?

Mass Update - Questions - Solved

Posted: 2019-08-05 19:18
by rprevost
OK, i finally succeeded in creating all my mass update function.
After messing things around by creating many projects for the same ***.axp file, i decided to do some cleaning up to see if things would improve.
Here is what i did:
Delete all Mass Update Projects: Projects to delete are in /plugins/projects
Delete all commands already created: Mass Update plugin creates a php file for each command you created. These files appear in the /hooks directory in the form of ajax-mass-update-name_of_table-name_of_field-weird_alphanumeric_characters.php

Note that Mass Update pluging will modifier the file on the server side. So make sure that, if you need to modify this file on your computer, you first download the latest file from the server.

I then reloaded the ***.axp file and created my commands. Outputted to the correct directory on the server. Tried the different commands in the app to confirm that everything was working perfectly (dropdown choices and date picker to mass update fields).

Thank you for this plugin, worth every penny for my users. Another satisfied customer.