5.75: New (bootstrap) CSS not available

Please report bugs and any annoyances here. Kindly include all possible details: steps to reproduce, expected result, actual result, screenshots, ... etc.
Post Reply
onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

5.75: New (bootstrap) CSS not available

Post by onoehring » 2019-06-22 09:56

Hi,

short: CSS is not properly when ...
when: the first line is (example):

Code: Select all

@import url("https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,700,400italic");
After I remove this line, the error I describe below is gone and the CSS correctly shown in the list.
Also I can place the line in the line following initial CSS comments - then everything works as well.

[edit]Actually, I notice, when I rename the file to lumen1.css everything works as well .... How come? Renaming the CSS file works, but the original filename does not? Very strange.[/edit]

I wanted to try the described way to implement a new CSS layout.
I downloaded the Lumen bootstrap css from bootswatch.com, renamed it to lumen.css and places it in the folder of the description on the Application Theme -> More Themes register.
There it reads:
To install the theme in AppGini, so that you can select it here, please follow these steps:

1. Rename the theme file from "bootstrap.css" to any other name you'd like to use here,
for example "nature.css" or a similar name (you must keep the ".css" extension).

2. Copy the renamed theme file to:
"C:\Program Files (x86)\AppGini\add-ons\themes".

3. (Optional step) If you'd like to see preview screenshots of the new theme in
this dialog, create a table view screenshot and name it {theme-name}-table-view.png
and save it to the same folder of step 2. Also make a screenshot of the detail view
and name it {theme-name}-detail-view.png and save to the same folder.

4. Finally, you can find the new theme available here in the themes drop-down in the
the "Preview" tab.
Even after multiple restarts of AG, the theme is not available in the dropdown as it should be:
ec31_bs_missing.png
ec31_bs_missing.png (139.93 KiB) Viewed 320 times
Olaf

Post Reply