Error when generating project with 5.73/5,74

Please report bugs and any annoyances here. Kindly include all possible details: steps to reproduce, expected result, actual result, screenshots, ... etc.
Post Reply
dannybridi
Posts: 14
Joined: 2016-03-21 19:33

Error when generating project with 5.73/5,74

Post by dannybridi » 2019-02-10 22:08

Hello,

I have been using ver 5.62 without issues. I downloaded and installed the latest version 5.74, but when I regenerate the project, I get a 500 error. The PHP error log file error_log shows the following:
[09-Feb-2019 14:45:34] PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in /****************/lib.php on line 41
I checked lib.php, but couldn't really find a missing ")" at line 41. I tried version 5.73, but got the same error. I reinstalled version 5.62 and all is OK again.

Any ideas?

Thanks

peebee
AppGini Super Hero
AppGini Super Hero
Posts: 207
Joined: 2013-03-21 04:37

Re: Error when generating project with 5.73/5,74

Post by peebee » 2019-02-11 03:09

What version of PHP are you running?

Not sure as I haven't seen lib.php in V5.73 or 5.74 yet but it is possibly an anonymous function causing the error? Anonymous functions are not supported on PHP < 5.3

If that is the problem and if you are running PHP 5.2 or lower, you would be well advised to upgrade

dannybridi
Posts: 14
Joined: 2016-03-21 19:33

Re: Error when generating project with 5.73/5,74

Post by dannybridi » 2019-02-11 07:28

Hello peebee,

Thanks for your reply. My hosting server's cPanel says PHP version 7.0.33, but phpMyAdmin says PHP version 5.6.30.

Thanks for your help

dannybridi
Posts: 14
Joined: 2016-03-21 19:33

Re: Error when generating project with 5.73/5,74

Post by dannybridi » 2019-02-11 10:09

Update,
The PHP version is 7.0.33
Thanks

Post Reply