Mobile Redirect Problems

Please report bugs and any annoyances here. Kindly include all possible details: steps to reproduce, expected result, actual result, screenshots, ... etc.
Post Reply
jangle
Veteran Member
Posts: 84
Joined: 2020-01-18 17:41

Mobile Redirect Problems

Post by jangle » 2021-07-21 21:05

Hello Experts,

I host with Gate and use website builder for a website. I have link that link to and appgini app. Everything work fine when accessing from a computer. However when accessing from a mobile device, to site adds "mobile" to the url. Of course then my AppGini app cannot be found because mobile is not part of the url.

Try https://allfirstrespondersmatter.org/AFRM/
Then mobile.allfirstrespondersmatter.org/AFRM/

Any thoughts?

Thanks

jangle
Veteran Member
Posts: 84
Joined: 2020-01-18 17:41

Re: Mobile Redirect Problems

Post by jangle » 2021-07-24 15:31

Still working on this.

I think one way to resolve the file not found would be to load my appgini files to both the the web directory and also to the mobile directory.

If there any reason that this should not be done? Meaning having the appgini files in two locations?

Thanks in advance.

Jim

User avatar
jsetzer
AppGini Super Hero
AppGini Super Hero
Posts: 1126
Joined: 2018-07-06 06:03
Location: Kiel, Germany
Contact:

Re: Mobile Redirect Problems

Post by jsetzer » 2021-07-24 16:41

If I got it right, this is not a problem of appgini but a problem of your website builder tool which seems to generate relative URL's rather than absolute URL's. Can you create absolute URL's giving the full protocol, server and path? Don't know why any website building tool should prepend anything to a fully defined absolute URL.

If you can't: If it always prepends "mobile." maybe you can create a subdomain in your hosting package and internally redirect that subdomain to the appgini directory.

I'm using subdomains a lot and usually this works just fine.
Kind regards,
<js />

jangle
Veteran Member
Posts: 84
Joined: 2020-01-18 17:41

Re: Mobile Redirect Problems

Post by jangle » 2021-07-26 14:51

Yes sir, not an appgini problem, but one with my web designer.

However as always, your information was very valuable.

"If it always prepends "mobile." maybe you can create a subdomain in your hosting package and internally redirect that subdomain to the appgini directory."

WORKED and solved my problem.

Thank you!!!

Jim

Post Reply