Strange Text In APPS

Please report bugs and any annoyances here. Kindly include all possible details: steps to reproduce, expected result, actual result, screenshots, ... etc.
Post Reply
rpierce
Posts: 25
Joined: 2018-11-26 13:55

Strange Text In APPS

Post by rpierce » 2020-05-22 22:25

Hello,

I have been having an issue with a small text string that appears throughout any ap I develop with AppGini. I mentioned it a while ago and someone suggested that I delete all files and re upload them to the server. I have done this. I have also recently upgraded to the most recent version of AppGini and the problem persists. It is a cross browser problem. I sure hope someone can help me figure this out.

I have attached screenshots with the problem text highlighted.
Attachments
thead1.JPG
thead1.JPG (46.44 KiB) Viewed 1406 times
thead2.JPG
thead2.JPG (35.24 KiB) Viewed 1406 times

pböttcher
AppGini Super Hero
AppGini Super Hero
Posts: 869
Joined: 2018-04-01 10:12

Re: Strange Text In APPS

Post by pböttcher » 2020-05-23 07:25

Hi,

as it looks like in you screen-shots this text displays after a date field.

Do you have an code that tries to manipulate a date field?
Otherwise, try create a small new app with a date field an see if this text shows up again.

rpierce
Posts: 25
Joined: 2018-11-26 13:55

Re: Strange Text In APPS

Post by rpierce » 2020-05-23 21:31

> pböttcher,

Thank you for the response. I had thought the same thing, that it was showing up in date fields. No, I have no code manipulating date fields outside of AppGini. The anomaly also appears in other areas of my Apps as illustrated in the attached screen shots:

As mentioned, I have completely deleted all of the files from the server and regenerated them using AppGini 5.82.

I hope I don't need to completely rebuild the app to eliminate this. But, if it must be........

Thanks for your help.

Ray
Attachments
thead4.JPG
thead4.JPG (62.5 KiB) Viewed 1348 times
thead3.JPG
thead3.JPG (19.37 KiB) Viewed 1348 times

User avatar
D Oliveira
AppGini Super Hero
AppGini Super Hero
Posts: 201
Joined: 2018-03-04 09:30
Location: Orlando, FL

Re: Strange Text In APPS

Post by D Oliveira » 2020-05-24 05:24

rpierce wrote:
2020-05-23 21:31
> pböttcher,

Thank you for the response. I had thought the same thing, that it was showing up in date fields. No, I have no code manipulating date fields outside of AppGini. The anomaly also appears in other areas of my Apps as illustrated in the attached screen shots:

As mentioned, I have completely deleted all of the files from the server and regenerated them using AppGini 5.82.

I hope I don't need to completely rebuild the app to eliminate this. But, if it must be........

Thanks for your help.

Ray

this is some html code for the tag <thead> that was left behind, you can try to inspect the element, use sublime text 3 using ctrl+shift+f to search your app folder for the exact inspected string and you should be able to pinpoint the issue, hope it helps.

Cheers

rpierce
Posts: 25
Joined: 2018-11-26 13:55

Re: Strange Text In APPS

Post by rpierce » 2020-05-26 15:47

Hello D Oliveira,

Thank you for helping. I am not a coder and will have to research how to use sublime text 3. Another question around this issue is what would be causing this lefto over HTML? I would think that regenerating all of the app files would eliminate this. It seems to be happening inside of Appgini because I don't go in and manipulate the code on my own.

Would I have to go through every App I make to search for this errant string?

rpierce
Posts: 25
Joined: 2018-11-26 13:55

Re: Strange Text In APPS

Post by rpierce » 2020-05-26 15:58

Here are a couple of screen shots from the Web Page examiner in Chrome:
Attachments
thead5.JPG
thead5.JPG (66.9 KiB) Viewed 1311 times
thead6.JPG
thead6.JPG (90.18 KiB) Viewed 1311 times

rpierce
Posts: 25
Joined: 2018-11-26 13:55

Re: Strange Text In APPS

Post by rpierce » 2020-05-26 16:36

I think I've figured this problem out. A while ago I found a script here in the forums that I had forgotten I was using. The script makes it so that you can scroll through tables and keep the top row visible. I removed it from the Hooks/footers-extras.php file and the problem is gone. I do however still want the top row visible with tables. Is there another script that anyone knows of? Or, could someone look this one over and possibly find the problem that is causing this "thead" text to appear?

Please and Thank You!

Code: Select all

<?php

    if($_SERVER['PHP_SELF'] == '/diary/index.php' && isset($_GET['signIn'])){
     ?>
     <style>
         body{
             background
         }
        
         
     </style>
     <?php
    }

?>

<?php if ($_REQUEST['Print_x'] != 1) { 
echo $_REQUEST['Print_x'];  
echo <<<EOT
<style>

.table-responsive { overflow: auto; width: 100%; height: 66vh; }   
.table  th { background:#eef; }
</style>
		
<script>
\$j('table').append($j('thead'));
// check for IE
if (navigator.userAgent.search("NET4.0") >= 0) {
	\$j('div.table-responsive').on('scroll', function() {
	  \$j('th', this).css('transform', 'translateY('+ this.scrollTop +'px)');
	});

}
else {
	if (navigator.userAgent.search("Edge") >= 0) {  // check for Edge
		\$j('.table-responsive').find('th').each(function() {\$j(this).css({"position": "sticky", "top": "0"})});
	}
	\$j('div.table-responsive').on('scroll', function() {
	  \$j('thead', this).css('transform', 'translateY('+ this.scrollTop +'px)');
	});
}
</script>;	
EOT;
 } ?>

rpierce
Posts: 25
Joined: 2018-11-26 13:55

Re: Strange Text In APPS

Post by rpierce » 2020-05-26 16:55

This forum is so great!! I searched and found another script that seems to work just fine!!

viewtopic.php?f=4&t=2673&p=10582&hilit=scroll#p10582

Post Reply