AppGini 5.80 Build 1072

Please report bugs and any annoyances here. Kindly include all possible details: steps to reproduce, expected result, actual result, screenshots, ... etc.
Post Reply
mysh_eireannach
Posts: 15
Joined: 2016-02-16 22:31

AppGini 5.80 Build 1072

Post by mysh_eireannach » 2019-10-08 10:47

Hi All

Updated to AppGini 5.80 Build 1072, open existing project, add some tables => Generated new php=> Uploaded to server

After tried add new record, received error massage:

Screenshot 2019-10-08 at 11.41.14.png
Screenshot 2019-10-08 at 11.41.14.png (56.17 KiB) Viewed 227 times
Then tried rebuild fields from admin area, and received another error massage:

Screenshot 2019-10-08 at 11.38.40.png
Screenshot 2019-10-08 at 11.38.40.png (28.26 KiB) Viewed 227 times
Then using phpmyadmin, checked if new tables exist in database, no new app do not insert new tables, and rebuild fields utility not helps.

Could anyone can try to do the same?

mekin
Posts: 29
Joined: 2019-04-22 17:09

Re: AppGini 5.80 Build 1072

Post by mekin » 2019-10-08 11:54

Getting a "Run-time error 5" when exporting project.

User avatar
a.gneady
Site Admin
Posts: 1033
Joined: 2012-09-27 14:46
Contact:

Re: AppGini 5.80 Build 1072

Post by a.gneady » 2019-10-08 14:58

mysh_eireannach wrote:
2019-10-08 10:47
Hi All

Updated to AppGini 5.80 Build 1072, open existing project, add some tables => Generated new php=> Uploaded to server

After tried add new record, received error massage:


Screenshot 2019-10-08 at 11.41.14.png

Then tried rebuild fields from admin area, and received another error massage:


Screenshot 2019-10-08 at 11.38.40.png

Then using phpmyadmin, checked if new tables exist in database, no new app do not insert new tables, and rebuild fields utility not helps.

Could anyone can try to do the same?
Please try to regenerate the app, making sure to overwrite all existing files, then upload to your server, making sure to overwrite all files.
:idea: Learn all the tips and tricks of customizing AppGini apps through our online course.
:arrow: Mass Update plugin: Update multiple records at once and improve your workflow efficiency.
:arrow: Summary Reports plugin: Build powerful reports and charts for your AppGini apps.
:arrow: Search Page Maker: Compose user-friendly yet powerful search pages for your AppGini apps.

User avatar
a.gneady
Site Admin
Posts: 1033
Joined: 2012-09-27 14:46
Contact:

Re: AppGini 5.80 Build 1072

Post by a.gneady » 2019-10-08 14:59

mekin wrote:
2019-10-08 11:54
Getting a "Run-time error 5" when exporting project.
Please send me the AXP project file to inspect this issue. You can send it to me via https://bigprof.com/appgini/support-request
:idea: Learn all the tips and tricks of customizing AppGini apps through our online course.
:arrow: Mass Update plugin: Update multiple records at once and improve your workflow efficiency.
:arrow: Summary Reports plugin: Build powerful reports and charts for your AppGini apps.
:arrow: Search Page Maker: Compose user-friendly yet powerful search pages for your AppGini apps.

onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

Re: AppGini 5.80 Build 1072

Post by onoehring » 2019-10-08 15:28

Hi,

is it just me? I can not see any technical documentation. All it says is "No Access To Page" ...
ec201.png
ec201.png (22.36 KiB) Viewed 201 times

Olaf

onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

Re: AppGini 5.80 Build 1072

Post by onoehring » 2019-10-08 15:34

Hi mysh_eireannach,

looking at the (too) small image of your SQL error it seems to me that it's worth trying to run that SQL using phpmyadmin. Does it work?
Did you change servers (Linux <-> Windows)? I had some troubles with that (see: viewtopic.php?f=4&t=3246 )

Also, your SQL says "GROUP=NULL ..." can those fields be NULL? If those fields are NULL by default, maybe it helps leaving these columns out?

Olaf

mysh_eireannach
Posts: 15
Joined: 2016-02-16 22:31

Re: AppGini 5.80 Build 1072

Post by mysh_eireannach » 2019-10-08 15:48

Hi a.gneady.

Yes, helps solution
regenerate the app, making sure to overwrite all existing files, then upload to your server, making sure to overwrite all files.
Thanks! All work now!

tvloeimans
Posts: 20
Joined: 2019-03-20 13:46

Re: AppGini 5.80 Build 1072

Post by tvloeimans » 2019-10-08 18:17

onoehring wrote:
2019-10-08 15:28
All it says is "No Access To Page" ...
Same here...
©2019 - No rights reserved

mekin
Posts: 29
Joined: 2019-04-22 17:09

Re: AppGini 5.80 Build 1072

Post by mekin » 2019-10-09 07:16

a.gneady wrote:
2019-10-08 14:59
mekin wrote:
2019-10-08 11:54
Getting a "Run-time error 5" when exporting project.
Please send me the AXP project file to inspect this issue. You can send it to me via https://bigprof.com/appgini/support-request

Hello, send you the file, including a video-recordingw with the steps before the error.

User avatar
a.gneady
Site Admin
Posts: 1033
Joined: 2012-09-27 14:46
Contact:

Re: AppGini 5.80 Build 1072

Post by a.gneady » 2019-10-09 10:11

onoehring wrote:
2019-10-08 15:28
Hi,

is it just me? I can not see any technical documentation. All it says is "No Access To Page" ...
ec201.png


Olaf
Hmm ... it seems AppGini is unable to write to your temp folder ... Please try this: click the "Application theme" icon in the toolbar in AppGini (the one with a color palette), then click the button "Preview in web browser". This should open a browser window, displaying a preview of the selected theme. Does this work? It uses the same procedure of writing the preview file to the temp folder.
:idea: Learn all the tips and tricks of customizing AppGini apps through our online course.
:arrow: Mass Update plugin: Update multiple records at once and improve your workflow efficiency.
:arrow: Summary Reports plugin: Build powerful reports and charts for your AppGini apps.
:arrow: Search Page Maker: Compose user-friendly yet powerful search pages for your AppGini apps.

User avatar
a.gneady
Site Admin
Posts: 1033
Joined: 2012-09-27 14:46
Contact:

Re: AppGini 5.80 Build 1072

Post by a.gneady » 2019-10-09 10:13

mekin wrote:
2019-10-09 07:16
Hello, send you the file, including a video-recordingw with the steps before the error.
Thanks .. will check it and reply to you within a few hours.
:idea: Learn all the tips and tricks of customizing AppGini apps through our online course.
:arrow: Mass Update plugin: Update multiple records at once and improve your workflow efficiency.
:arrow: Summary Reports plugin: Build powerful reports and charts for your AppGini apps.
:arrow: Search Page Maker: Compose user-friendly yet powerful search pages for your AppGini apps.

mysh_eireannach
Posts: 15
Joined: 2016-02-16 22:31

Re: AppGini 5.80 Build 1072

Post by mysh_eireannach » 2019-10-09 10:53

onoehring wrote:
2019-10-08 15:34
Hi mysh_eireannach,

looking at the (too) small image of your SQL error it seems to me that it's worth trying to run that SQL using phpmyadmin. Does it work?
Did you change servers (Linux <-> Windows)? I had some troubles with that (see: viewtopic.php?f=4&t=3246 )

Also, your SQL says "GROUP=NULL ..." can those fields be NULL? If those fields are NULL by default, maybe it helps leaving these columns out?

Olaf
Hi Olaf

No, I not change anyting exept upgrade to AppGini 5.80 Build 1072.

I tried your solution rename all new tables to lower case, but not helps.

Error message shows:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Group='2', Message='Test', Author='14', Attachment_1='e5ae32e9fbf11364e.pdf', At' at line 1
Query:
INSERT INTO `company_notice_board` SET Date='2019-10-9', Group='2', Message='Test', Author='14', Attachment_1='e5ae32e9fbf11364e.pdf', Attachment_2=NULL
The above info is displayed because you are currently signed in as the super admin. Other users won't see this.

You could try fixing this issue from the Admin Area : Utilities menu : Rebuild Fields.
Utilities menu : Rebuild Fields. - Not Helps!
Regenerate the app - Not Helps!

onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

Re: AppGini 5.80 Build 1072

Post by onoehring » 2019-10-09 14:29

Hi Ahmed,
Hmm ... it seems AppGini is unable to write to your temp folder ... Please try this: click the "Application theme" icon in the toolbar in AppGini (the one with a color palette), then click the button "Preview in web browser". This should open a browser window, displaying a preview of the selected theme. Does this work? It uses the same procedure of writing the preview file to the temp folder.
yes, this does work. A new tab is opened in my default browser.

Olaf

onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

Re: AppGini 5.80 Build 1072

Post by onoehring » 2019-10-09 14:31

Hi mysh_eireannach,

did you try
... to run that SQL using phpmyadmin. Does it work?
Olaf

mysh_eireannach
Posts: 15
Joined: 2016-02-16 22:31

Re: AppGini 5.80 Build 1072

Post by mysh_eireannach » 2019-10-09 15:08

onoehring wrote:
2019-10-09 14:31
Hi mysh_eireannach,

did you try
... to run that SQL using phpmyadmin. Does it work?
Olaf
Hi Olaf,

You give me a good hint.

Sorted!

Problem was: I named one of my fields as 'group' and SQL query understand as syntax error.

INSERT INTO `company_notice_board` SET Date='2019-10-9', Group='2', Message='Test', Author='14', Attachment_1='e5ae32e9fbf11364e.pdf', Attachment_2=NULL

Renamed field as 'Group_w' , regenerated App, rebuild fields and problem disappear.

Conclusion:

Never name your fields as SQL commands!

Thanks for hints!

onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

Re: AppGini 5.80 Build 1072

Post by onoehring » 2019-10-09 16:10

Hi,

you are welcome - and indeed, a good idea how (not) to name fields.

Olaf

onoehring
AppGini Super Hero
AppGini Super Hero
Posts: 298
Joined: 2019-05-21 22:42
Contact:

Re: AppGini 5.80 Build 1072

Post by onoehring » 2019-10-10 05:49

Hi Ahmed,

I do not change anything (just restarted Windows and AG several times) - and now the technical docs show up (did not try technical docs for pages yet).
ec203.png
ec203.png (6.31 KiB) Viewed 86 times
Olaf

User avatar
a.gneady
Site Admin
Posts: 1033
Joined: 2012-09-27 14:46
Contact:

Re: AppGini 5.80 Build 1072

Post by a.gneady » 2019-10-10 12:36

Renamed field as 'Group_w' , regenerated App, rebuild fields and problem disappear.

Conclusion:

Never name your fields as SQL commands!
Actually this sounds like a bug as AppGini avoids similar errors by using back ticks around table and field names .. That is, if a field is named group, it shouldn't trigger an SQL error if it's used in queries as `group` ... So, it seems some queries are not quoting field named properly .. I'll investigate this issue and make a fix for it as soon as possible.
:idea: Learn all the tips and tricks of customizing AppGini apps through our online course.
:arrow: Mass Update plugin: Update multiple records at once and improve your workflow efficiency.
:arrow: Summary Reports plugin: Build powerful reports and charts for your AppGini apps.
:arrow: Search Page Maker: Compose user-friendly yet powerful search pages for your AppGini apps.

User avatar
a.gneady
Site Admin
Posts: 1033
Joined: 2012-09-27 14:46
Contact:

Re: AppGini 5.80 Build 1072

Post by a.gneady » 2019-10-10 12:39

onoehring wrote:
2019-10-10 05:49
I do not change anything (just restarted Windows and AG several times) - and now the technical docs show up (did not try technical docs for pages yet).
ec203.png
Thanks for the update ... I'll try to investigate this issue further and see if there is a way to handle it better.
:idea: Learn all the tips and tricks of customizing AppGini apps through our online course.
:arrow: Mass Update plugin: Update multiple records at once and improve your workflow efficiency.
:arrow: Summary Reports plugin: Build powerful reports and charts for your AppGini apps.
:arrow: Search Page Maker: Compose user-friendly yet powerful search pages for your AppGini apps.

Post Reply