Error (HTTP 500 Internal Server Error) after clicking on "import csv data"

Please report bugs and any annoyances here. Kindly include all possible details: steps to reproduce, expected result, actual result, screenshots, ... etc.
Flemp000
Posts: 3
Joined: 03 Jan 2017, 18:43

Error (HTTP 500 Internal Server Error) after clicking on "import csv data"

Postby Flemp000 » 03 Jan 2017, 19:00

After clicking on "import csv data" in firefox I get a blank screen when I try the same thing in IE I get "The website cannot display the page HTTP 500" . after looking at the Apche2 logs it says

:?: [Tue Jan 03 13:45:34.350096 2017] [:error] [pid 9160] [client 192.168.5.201:57552] PHP Warning: dir(/var/www/html/admin/csv): failed to open dir: No such file or directory in /var/www/html/admin/pageUploadCSV.php on line 309, referer: http://192.168.5.98/admin/pageHome.php

:?: [Tue Jan 03 13:45:34.358526 2017] [:error] [pid 9160] [client 192.168.5.201:57552] PHP Fatal error: Call to a member function read() on boolean in /var/www/html/admin/pageUploadCSV.php on line 310, referer: http://192.168.5.98/admin/pageHome.php

Can anyone please help?

Flemp000
Posts: 3
Joined: 03 Jan 2017, 18:43

Re: Error (HTTP 500 Internal Server Error) after clicking on "import csv data"

Postby Flemp000 » 04 Jan 2017, 02:29

Working on the Latest version is 5.60, released on Dec 25, 2016 (Appgini)

Noha Eshra
Moderator
Posts: 77
Joined: 11 Nov 2013, 19:21

Re: Error (HTTP 500 Internal Server Error) after clicking on "import csv data"

Postby Noha Eshra » 05 Jan 2017, 08:53

AppGini Application attempts to create a folder named CSV inside the admin folder. If it fails to create that folder, an error message should be displayed.
For some reason this didn't happen on your side.
Anyway you can create that folder (admin/csv) and make sure it's write-able by Appgini application.

Flemp000
Posts: 3
Joined: 03 Jan 2017, 18:43

Re: Error (HTTP 500 Internal Server Error) after clicking on "import csv data"

Postby Flemp000 » 08 Jan 2017, 01:17

I created the csv folder and changed the permissions and it works. Thank You for the help.


Return to “Bugs/annoyances”